AmazinglyJava
AmazinglyJava
Member

204 posts
IGN: AmazinglyJava
by AmazinglyJava » over 2 years ago
Every time I start up my server all armour stands with heads on are wearing Steve heads. If I take the head of the armour stand and place it, it shows up as the head it actually is. I'm changing their entitydata 20 times a second but I don't think that's the reason for the bug.

Properties the armour stands have:

Small:1 (I've got one that's not small and I experience the same problem)
NoGravity:1
Invisible:1 (You can still see the items of invisible armour stands.)
 
Edit: I'm able to fix this by stopping the entitydata command blocks and replacing all the skulls manually, but it takes time.

Edit x2: Previously every time I restarted my server all the heads became steve. Now they are only becoming steve heads 75% of the time, and if they were steve before the restart they become normal heads after it.



Last edited: over 2 years ago
I'm a developer! Message me if you need help!

Put "@Partydragen is a noob" in discord!
Partydragen
Partydragen
Owner

476 posts
IGN: Partydragen
by Partydragen » over 2 years ago
Well that must be a minecraft bug

Hopefully solved when we update to 1.12




Owner of CubedCraft Network
Server Ip: mc.cubedcraft.com
My Website:
 http://partydragen.com/
AmazinglyJava
AmazinglyJava
Member

204 posts
IGN: AmazinglyJava
by AmazinglyJava » over 2 years ago
Oh ok. It's really inconvenient unless you like making food inside someones head. :P

 




I'm a developer! Message me if you need help!

Put "@Partydragen is a noob" in discord!